вторник, 28 ноября 2017 г.

ЕГЭ-21: 29449E

Напишите в ответе число, которое будет напечатано в результате выполнения следующего алгоритма (для Вашего удобства алгоритм представлен на пяти языках программирования).


Бейсик
Python
DIM A, B, N, t AS INTEGER
A = -100: B = 100
N = 0
FOR t = A TO B
 IF F(t) <= 0 THEN
   N = N + 1
 END IF
NEXT t
PRINT N

FUNCTION F (x)
   F = 3*(x - 20)*(x + 34)
END FUNCTION
def f(x):
 return 3*(x - 20)*(x + 34)

a = -100
b = 100
n = 0

for t in range(a, b + 1):
 if f(t) <= 0:
   n = n + 1
print(n)

Алгоритмический язык
Паскаль
алг
нач
 цел a, b, N, t
 a := -100; b := 100
 N := 0
 нц для t от a до b
   если F(t) <= 0
     то
       N := N + 1
   все
 кц
 вывод N
кон
алг цел F(цел x)
нач
 знач := 3*(x - 20)*(x + 34)
кон
var a, b, N, t: integer;
Function F(x: integer):integer;
 begin
   F := 3*(x - 20)*(x + 34)
 end;
begin
 a := -100; b := 100;
 N := 0;
 for t := a to b do begin
   if (F(t) <= 0) then
     N := N + 1
 end;
 write(N)
end.
Си
#include<stdio.h>
int F(int x) {
 return 3*(x - 20)*(x + 34);
}
void main() {
 int a, b, N, t;
 a = -100; b = 100;
 N = 0;
 for (t = a; t <= b; t++) {
if (F(t) <= 0) {
  N++;
   }
 }
 printf("%d", N);
}
Ответ:
55

Комментариев нет:

Отправить комментарий